How do I fix the "Link service unavailable" thing?

Hi! Does anyone know how to help me with this issue? I got Venice Unleashed today, got Battlefield 3 and its expansions and shortcuts, and every time I log in to my VU client, it tries to link my EA account but fails to do so. The only thing it says is "Link service unavailable. From what I’ve seen, nobody’s had this issue except for me, and I’d really like to know how to circumvent it.


1 Like

Same issue here.

I have been trying to link to my EA APP account and so far I can’t do it. I get that “Link service unavailable” message.

Hope any fix soon.

Okay, so I just tried again first thing in the morning. Apparently it linked up in no time.

That’s pretty weird. Is it based on the time of day?

ZEUS (the backend of Venice Unleashed) was temporarily down due to an error on Amazon Web Services, that caused the issue :slight_smile:

Is this still the same? I have attempted all the guides but no success.

Firewall? Anything like that?

Yep, same issue here. “Link service unavailable” when starting VU.