VU Community Forums

MapList.txt not working

Hi there,

I just created my own server using the official documentation.
I´ve created a Ubuntu Server VM on my home server and followed the instructions for setting up a VU Server.
I had no problems so far, but I can´t change the map rotation.
I´ve created a MapList.txt file inside the ServerInstance/Admin Path.
My Admin folder looks like this:

~/vu/instance/Admin$ ls
BanList.txt MapList.txt Startup.txt

My MapList.txt:
MP_013 TeamDeathMatch0 2

Still the Server shows up with Operation Metro and Conquest.

Anyone got an idea what i missed?
My Startup.txt works fine (I can change the Server Name / max. players etc).

Edit:
Changing the map via Procon is possible

map rotation in linux is having issues, you should specify maps in the maplist.txt before run server.

Instead of passing a relative unix path you can use the winepath command to translate it to a wine-compatible windows path like so:

-serverInstancePath "$(winepath -w ~/vu/instance)"
2 Likes

Thanks, it worked!
As I´ve seen someone else having this issue with a linux server, it might be a good idea to add the information to the official documentation?

Yeah, it’ll be updated soon.

Same problem, server ok, join ok, but the settings not working

Startup txt not working
I tried some commands

vars.serverName XY not working
vars.friendlyFire not working
vars.gamePassword not working

Why? Solution?