VU Community Forums

[VU-MapVote] [GUI] Allow players to vote for the next map

Description

Just a simple MapVote Client GUI.

Download

Installation:

  1. Extract contect of zip to your mods folder. This should look something like Admin/Mods/vu-mapvote
  2. Add vu-mapvote to your Admin/ModList.txt
  3. Setup the maps you want in MapList.txt (without this it will not work! See example below)
  4. Voting starts at the endscreen

Optional configuration:

Add these to your Admin/Startup.txt

mapvote.randomize <true/false> (default true)
mapvote.limit <number of selectable random maps> (default 15)
mapvote.excludecurrentmap <true/false> (default true)

Manually starting a vote:

mapvote.start
mapvote.end

In Game:

MapList.txt example

MP_001 ConquestLarge0 1
MP_003 ConquestLarge0 1
MP_007 ConquestLarge0 1
MP_011 ConquestLarge0 1
MP_012 ConquestLarge0 1
MP_013 ConquestLarge0 1
MP_017 ConquestLarge0 1
MP_018 ConquestLarge0 1
MP_Subway ConquestLarge0 1
XP1_001 ConquestAssaultLarge0 1
XP1_002 ConquestAssaultLarge0 1
XP1_003 ConquestAssaultLarge0 1
XP1_004 ConquestAssaultLarge0 1

Source Code

Feel free to contribute. :slight_smile:

11 Likes

Looks awesome man! Thanks

2 Likes

This is great, good job!!!

1 Like

Hey, saw this mod one a server i joined and really liked it. I cloned the repo and tried to install it on my own server, but I always get this message on startup:
[error] [VeniceEXT] Could not find WebUI container for mod ‘vu-mapvote’.

I also tried to compile the web container myself but then i get this message:
[2020-12-31 16:43:05+01:00] [info] [VeniceEXT] [vu-chaos] Loaded VeniceEXT shared script: shared/init.lua
[2020-12-31 16:43:05+01:00] [info] [VeniceEXT] [vu-chaos] Loaded VeniceEXT server script: init.lua
[2020-12-31 16:43:05+01:00] [info] [VeniceEXT] [vu-chaos] Compiling client module…
[2020-12-31 16:43:05+01:00] [info] [VeniceEXT] [vu-chaos] Compiling shared script ‘init.lua’…
[2020-12-31 16:43:05+01:00] [info] [VeniceEXT] [vu-chaos] Compiling client script ‘init.lua’…
[2020-12-31 16:43:05+01:00] [info] [VeniceEXT] Successfully loaded VeniceEXT module ‘vu-chaos’.
[2020-12-31 16:43:05+01:00] [info] [VeniceEXT] Loading VeniceEXT module ‘vu-mapvote’.
[2020-12-31 16:43:06+01:00] [error] [VeniceEXT] HTTP Request failed with error ‘Certificate validation error: Failed to verify certificate chain: CA not trusted’.
[2020-12-31 16:43:06+01:00] [error] [VeniceEXT] [vu-mapvote] Failed to load VeniceEXT server script: init.lua. Error: [string “init.lua”]:9: attempt to index a nil value (global ‘res’)
stack traceback:
[string “init.lua”]:9: in function ‘base.getCurrentVersion’
[string “init.lua”]:16: in function ‘base.checkVersion’
[string “init.lua”]:20: in main chunk
[2020-12-31 16:43:06+01:00] [info] [VeniceEXT] [vu-mapvote] Compiling client module…
[2020-12-31 16:43:06+01:00] [info] [VeniceEXT] [vu-mapvote] Compiling shared script ‘version.lua’…
[2020-12-31 16:43:06+01:00] [info] [VeniceEXT] [vu-mapvote] Compiling client script ‘init.lua’…
[2020-12-31 16:43:06+01:00] [error] [VeniceEXT] Failed to load VeniceEXT module ‘vu-mapvote’.
[2020-12-31 16:43:06+01:00] [info] [VeniceEXT] Unloading VeniceEXT module ‘vu-mapvote’.
[2020-12-31 16:43:06+01:00] [error] [VeniceEXT] An error occurred during mod loading. Further loading operations have been cancelled.

1 Like

Hey, thanks to hear that.
Can you try the latest version(released it just now), it disables the certificate validation for updates.
Are you using wine?

Yes, I’m using wine, but wine should use the certs installed on my linux machine. Maybe it’s just another vu on linux quirk. Got it running by removing the http request and always returning a hardcoded version number - not optimal, because of updates.

EDIT:
Tried the new version, cloned from git repo, compiled ui, started the server - Same error as previous. Maybe it’s a problem with VeniceEXT

1 Like

Opened an Issue for this, I’ll look into it.

1 Like

you’re the best. Would have tested around a bit myself if i wasnt so lazy. I’d be happy to check back whether your changes have fixed it or not. if you need more info about my system just ask

1 Like

Awesome mod! Only better it can be if there will be 9 maps on one page, but it’s not so important

1 Like

Should be fixed now. :slight_smile:

Is this now working for Rush gamemode?

edit: hmm still seems to trigger every round. is there a way of making it only trigger in the second round?

1 Like

Maybe if he updates it and checks the mapList.round rcon command or whatever it’s called. But tbh I have no idea, never checked the source

1 Like

I fixed triggering the vote only for the last round in the upcomming-release branch which doesnt have automatic builds and isnt merged to master yet. If you want it already you can just get the server lua file from here https://gitlab.com/n4gi0s/vu-mapvote/-/tree/upcomming-release since that is the only thing that has changed. It will get merged soon most likely.

1 Like

Its merged into the current version 1.1.8. Thanks for your work.

1 Like

thats awesome, thanks for your work all. I’ll put this back on my server when empty. :slight_smile:

1 Like

this looks dope! can’t wait to throw it on a server!

1 Like

Hello,
Is it possible to add an option to start voting when there are only 100 tickets left in a team and end mapvote is 0 ticket for example?

Thanks a lot for your work ! :grinning:

Have installed the mod.
Also get the error. :frowning:

[error] [VeniceEXT] Could not find WebUI container for mod ‘vu-mapvote’.

Run the server with Debian 10 + Wine.

Edit: Just tested it on my Windows 10 PC. Here I also get the same error.

And now what do you expect? No one has magic jars in which we can see what’s the solution. For me the mod worked right away, so I guess you are missing something. Running in Docker on Debian. Check if you have all the requirements installed.

You didn’t download the compiled version.

1 Like